Thank you for visiting the Rackspace Community
The The Community is live! Post new content or topics so our teams can assist.

Please contact your support team if you have a question or need assistance for any Rackspace products, services, or articles.

Unable to Install EPEL and IUS repositories on CentOS

I'm trying to follow the instructions in the article Install EPEL, IUS, and Remi repositories on CentOS and Red Hat (https://support.rackspace.com/how-to/install-epel-and-additional-repositories-on-centos-and-red-hat/).

After entering the command:

sudo yum install epel-release

I get this result:

Loaded plugins: fastestmirror, rhnplugin, security
This system is receiving updates from RHN Classic or Red Hat Satellite.
Setting up Install Process
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package epel-release.noarch 0:6-8 will be installed
--> Processing Conflict: rs-epel-release-1.0-2.rs.centos6.noarch conflicts epel-release
--> Processing Conflict: rs-epel-release-1.0-2.rs.centos6.noarch conflicts epel-release
--> Finished Dependency Resolution
Error: rs-epel-release conflicts with epel-release-6-8.noarch
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

It would appear that epel-release-6-8.noarc is already installed.  Entering the command:

yum repolist

Seems to confirm this:

repo id repo name status
dell-system-update_dependent dell-system-update_dependent 62
dell-system-update_independent dell-system-update_independent 576
rackspace Rackspace Monitoring 1
rs-epel Extra Packages for Enterprise Linux 6 - 12,178+1
repolist: 12,817

Continuing following the instructions, I enter:

wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm

and get:

--2016-12-14 02:30:03-- https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm
Resolving dl.fedoraproject.org... 209.132.181.23, 209.132.181.24, 209.132.181.25, ...
Connecting to dl.fedoraproject.org|209.132.181.23|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 14540 (14K) [application/x-rpm]
Saving to: “epel-release-latest-6.noarch.rpm.2”

100%[======================================>] 14,540 --.-K/s in 0.04s

2016-12-14 02:30:03 (377 KB/s) - “epel-release-latest-6.noarch.rpm.2” saved [14540/14540]

This appears to have worked, so then continuing, I enter:

sudo rpm -Uvh epel-release-6*.rpm

which produces the following error:


error: File not found by glob: epel-release-6*.rpm

The instructions state that a File not Found error could be due to a version change and suggest visiting https://fedoraproject.org/wiki/EPEL

This site states that for CentOS users, the following command should work:

yum install epel-release

However, this produces the following:

Loaded plugins: fastestmirror, rhnplugin, security
This system is receiving updates from RHN Classic or Red Hat Satellite.
Setting up Install Process
Loading mirror speeds from cached hostfile
dell-system-update_dependent | 2.3 kB 00:00
dell-system-update_independent | 2.3 kB 00:00
rackspace | 1.3 kB 00:00
rs-epel | 4.3 kB 00:00
Resolving Dependencies
--> Running transaction check
---> Package epel-release.noarch 0:6-8 will be installed
--> Processing Conflict: rs-epel-release-1.0-2.rs.centos6.noarch conflicts epel-release
--> Processing Conflict: rs-epel-release-1.0-2.rs.centos6.noarch conflicts epel-release
--> Finished Dependency Resolution
Error: rs-epel-release conflicts with epel-release-6-8.noarch
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Parents Reply Children
No Data