Thank you for visiting the Rackspace Community
The The Community is live! Post new content or topics so our teams can assist.

Please contact your support team if you have a question or need assistance for any Rackspace products, services, or articles.

Help~who can give me a link about how to deploy the RackSpace private OpenStack v11.2 in all-in-one mode?

This question is answered.

 Hi Gentleman:

Help~who can give me a link about how to deploy the RackSpace private OpenStack v11.2 in all-in-one mode?

I find the link in the website,But it tell me  :A recommended minimal layout for installing RPCO involves five target hosts in total.

Environment:

1.installed in a physical server;

2.the OS:Ubuntu 14.04+RPCO 11.2(Kilo)

3.Block storage:cinder

it is true? 

Verified Answer
All Replies
  • It is possible to install on one physical host. Of course this is only for testing. There is an AIO guide in the developer docs: http://docs.openstack.org/developer/openstack-ansible/developer-docs/index.html

    By the way, you are two major versions behind. The latest OpenStack-Ansible (which was born out of Rackspace Private Cloud) is 13.1.1 "Mitaka".

  • +1 to what Stoner said...

    Also, that note about device count is for deploying on production environments. As you mentioned you are interested in installing the all-in-one, that does not apply as you are installing the "ALL-in-ONE," meaning all services in one device. Also, as Stoner mentioned, not recommended for production use. This is for testing and learning purposes ONLY.

  • Stoner:

    Thanks very much.

    Yeah ~ I just want to test the block storage and swift. So I think I can use the AIO mode. I will follow your guide to deploy it.

    "Mitaka" was released in last mouth~ RPC release the product for "Mitaka" fastlly. It is wonderful~Yes

  • Stoner:

    Ubuntu 14.04/RPC 11

    I follow the guide to deploy the RPC in AIO mode.when I excute step:./scripte/bootstrap-ansible.sh, it is failed .can you help me to find the reason?

    Log:

    Connnection object at 0x7fe7af94c850>: Failed to establish a new connection: [Errno -2] Name or service not known',)': /packages/9c/32/004ce0852e0a127f07f358b715015763273799bd798956fa930814b60f39/pip-8.1.2-py2.py3-none-any.whl
    /usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
    SNIMissingWarning
    /usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
    InsecurePlatformWarning
    Retrying (Retry(total=2, connect=None, read=None, redirect=None)) after connection broken by 'ReadTimeoutError("HTTPSConnectionPool(host='pypi.python.org', port=443): Read timed out. (read timeout=15)",)': /packages/9c/32/004ce0852e0a127f07f358b715015763273799bd798956fa930814b60f39/pip-8.1.2-py2.py3-none-any.whl
    /usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
    InsecurePlatformWarning
    Downloading pip-8.1.2-py2.py3-none-any.whl (1.2MB)
    100% |████████████████████████████████| 1.2MB 23kB/s
    Collecting setuptools==22.0.0
    Downloading setuptools-22.0.0-py2.py3-none-any.whl (509kB)
    94% |██████████████████████████████▏ | 481kB 4.3kB/s eta 0:00:07Exception:
    Traceback (most recent call last):
    File "/usr/local/lib/python2.7/dist-packages/pip/basecommand.py", line 209, in main
    status = self.run(options, args)
    File "/usr/local/lib/python2.7/dist-packages/pip/commands/install.py", line 310, in run
    wb.build(autobuilding=True)
    File "/usr/local/lib/python2.7/dist-packages/pip/wheel.py", line 748, in build
    self.requirement_set.prepare_files(self.finder)
    File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 360, in prepare_files
    ignore_dependencies=self.ignore_dependencies))
    File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 577, in _prepare_file
    session=self.session, hashes=hashes)
    File "/usr/local/lib/python2.7/dist-packages/pip/download.py", line 810, in unpack_url
    hashes=hashes
    File "/usr/local/lib/python2.7/dist-packages/pip/download.py", line 649, in unpack_http_url
    hashes)
    File "/usr/local/lib/python2.7/dist-packages/pip/download.py", line 871, in _download_http_url
    _download_url(resp, link, content_file, hashes)
    File "/usr/local/lib/python2.7/dist-packages/pip/download.py", line 595, in _download_url
    hashes.check_against_chunks(downloaded_chunks)
    File "/usr/local/lib/python2.7/dist-packages/pip/utils/hashes.py", line 46, in check_against_chunks
    for chunk in chunks:
    File "/usr/local/lib/python2.7/dist-packages/pip/download.py", line 563, in written_chunks
    for chunk in chunks:
    File "/usr/local/lib/python2.7/dist-packages/pip/utils/ui.py", line 139, in iter
    for x in it:
    File "/usr/local/lib/python2.7/dist-packages/pip/download.py", line 552, in resp_read
    decode_content=False):
    File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/response.py", line 344, in stream
    data = self.read(amt=amt, decode_content=decode_content)
    File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/response.py", line 311, in read
    flush_decoder = True
    File "/usr/lib/python2.7/contextlib.py", line 35, in __exit__
    self.gen.throw(type, value, traceback)
    File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/response.py", line 240, in _error_catcher
    raise ReadTimeoutError(self._pool, None, 'Read timed out.')
    ReadTimeoutError: HTTPSConnectionPool(host='pypi.python.org', port=443): Read timed out.
    You are using pip version 8.1.1, however version 8.1.2 is available.
    You should consider upgrading via the 'pip install --upgrade pip' command.
    + pip install --upgrade --isolated pip==8.1.2 setuptools==22.0.0 wheel==0.29.0
    Collecting pip==8.1.2
    /usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
    SNIMissingWarning
    /usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
    InsecurePlatformWarning
    Using cached pip-8.1.2-py2.py3-none-any.whl
    Collecting setuptools==22.0.0
    Downloading setuptools-22.0.0-py2.py3-none-any.whl (509kB)
    100% |████████████████████████████████| 512kB 13kB/s
    Requirement already up-to-date: wheel==0.29.0 in /usr/local/lib/python2.7/dist-packages
    Installing collected packages: pip, setuptools
    Found existing installation: pip 8.1.1
    Uninstalling pip-8.1.1:
    Successfully uninstalled pip-8.1.1
    Found existing installation: setuptools 20.7.0
    Uninstalling setuptools-20.7.0:
    Successfully uninstalled setuptools-20.7.0
    Successfully installed pip-8.1.2 setuptools-22.0.0
    + PIP_OPTS=
    + '[' -n '' ']'
    + '[' -n '' ']'
    + PIP_COMMAND=pip2
    ++ which pip2
    + '[' '!' /usr/local/bin/pip2 ']'
    + pip2 install -r requirements.txt
    Requirement already satisfied (use --upgrade to upgrade): netaddr>=0.7.12 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 1))
    Requirement already satisfied (use --upgrade to upgrade): PrettyTable<0.8,>=0.7 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 2))
    Requirement already satisfied (use --upgrade to upgrade): pycrypto>=2.6 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 3))
    Requirement already satisfied (use --upgrade to upgrade): PyYAML>=3.1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 4))
    Collecting virtualenv>=14.0.0 (from -r requirements.txt (line 5))
    /usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
    SNIMissingWarning
    /usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
    InsecurePlatformWarning
    Downloading virtualenv-15.0.2-py2.py3-none-any.whl (1.8MB)
    100% |████████████████████████████████| 1.8MB 19kB/s
    Requirement already satisfied (use --upgrade to upgrade): pip==8.1.2 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 10))
    Requirement already satisfied (use --upgrade to upgrade): setuptools==22.0.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 11))
    Requirement already satisfied (use --upgrade to upgrade): wheel==0.29.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 12))
    Installing collected packages: virtualenv
    Successfully installed virtualenv-15.0.2
    ++ which python2
    + PYTHON_EXEC_PATH=/usr/bin/python2
    + virtualenv --always-copy --system-site-packages --python=/usr/bin/python2 /opt/ansible-runtime
    Running virtualenv with interpreter /usr/bin/python2
    New python executable in /opt/ansible-runtime/bin/python2
    Also creating executable in /opt/ansible-runtime/bin/python
    Installing setuptools, pip, wheel...
    done.
    + PIP_OPTS+=' --upgrade'
    + PIP_COMMAND=/opt/ansible-runtime/bin/pip
    + /opt/ansible-runtime/bin/pip install --upgrade -r requirements.txt /opt/ansible_v1.9.4-1
    Processing /opt/ansible_v1.9.4-1
    Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'NewConnectionError('<pip._vendor.requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x7f9868b85ad0>: Failed to establish a new connection: [Errno -2] Name or service not known',)': /simple/netaddr/
    /opt/ansible-runtime/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
    SNIMissingWarning
    /opt/ansible-runtime/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
    InsecurePlatformWarning
    Requirement already up-to-date: netaddr>=0.7.12 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 1))
    Requirement already up-to-date: PrettyTable<0.8,>=0.7 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 2))
    Requirement already up-to-date: pycrypto>=2.6 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 3))
    Requirement already up-to-date: PyYAML>=3.1.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 4))
    Requirement already up-to-date: virtualenv>=14.0.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 5))
    Requirement already up-to-date: pip==8.1.2 in /opt/ansible-runtime/lib/python2.7/site-packages (from -r requirements.txt (line 10))
    Collecting setuptools==22.0.0 (from -r requirements.txt (line 11))
    Using cached setuptools-22.0.0-py2.py3-none-any.whl
    Requirement already up-to-date: wheel==0.29.0 in /opt/ansible-runtime/lib/python2.7/site-packages (from -r requirements.txt (line 12))
    Collecting paramiko (from ansible==1.9.4)
    Downloading paramiko-2.0.0-py2.py3-none-any.whl (170kB)
    Exception:
    Traceback (most recent call last):
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/commands/install.py", line 310, in run
    wb.build(autobuilding=True)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/wheel.py", line 750, in build
    self.requirement_set.prepare_files(self.finder)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/req/req_set.py", line 370, in prepare_files
    ignore_dependencies=self.ignore_dependencies))
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/req/req_set.py", line 587, in _prepare_file
    session=self.session, hashes=hashes)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/download.py", line 810, in unpack_url
    hashes=hashes
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/download.py", line 649, in unpack_http_url
    hashes)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/download.py", line 871, in _download_http_url
    _download_url(resp, link, content_file, hashes)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/download.py", line 595, in _download_url
    hashes.check_against_chunks(downloaded_chunks)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/utils/hashes.py", line 46, in check_against_chunks
    for chunk in chunks:
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/download.py", line 563, in written_chunks
    for chunk in chunks:
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/utils/ui.py", line 139, in iter
    for x in it:
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/download.py", line 552, in resp_read
    decode_content=False):
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/response.py", line 353, in stream
    data = self.read(amt=amt, decode_content=decode_content)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/response.py", line 320, in read
    flush_decoder = True
    File "/usr/lib/python2.7/contextlib.py", line 35, in __exit__
    self.gen.throw(type, value, traceback)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/response.py", line 242, in _error_catcher
    raise ReadTimeoutError(self._pool, None, 'Read timed out.')
    ReadTimeoutError: HTTPSConnectionPool(host='pypi.python.org', port=443): Read timed out.
    + /opt/ansible-runtime/bin/pip install --isolated --upgrade /opt/ansible_v1.9.4-1
    Processing /opt/ansible_v1.9.4-1
    Collecting paramiko (from ansible==1.9.4)
    /opt/ansible-runtime/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
    SNIMissingWarning
    /opt/ansible-runtime/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
    InsecurePlatformWarning
    Downloading paramiko-2.0.0-py2.py3-none-any.whl (170kB)
    89% |████████████████████████████▊ | 153kB 15kB/s eta 0:00:02Exception:
    Traceback (most recent call last):
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/commands/install.py", line 310, in run
    wb.build(autobuilding=True)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/wheel.py", line 750, in build
    self.requirement_set.prepare_files(self.finder)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/req/req_set.py", line 370, in prepare_files
    ignore_dependencies=self.ignore_dependencies))
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/req/req_set.py", line 587, in _prepare_file
    session=self.session, hashes=hashes)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/download.py", line 810, in unpack_url
    hashes=hashes
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/download.py", line 649, in unpack_http_url
    hashes)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/download.py", line 871, in _download_http_url
    _download_url(resp, link, content_file, hashes)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/download.py", line 595, in _download_url
    hashes.check_against_chunks(downloaded_chunks)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/utils/hashes.py", line 46, in check_against_chunks
    for chunk in chunks:
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/download.py", line 563, in written_chunks
    for chunk in chunks:
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/utils/ui.py", line 139, in iter
    for x in it:
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/download.py", line 552, in resp_read
    decode_content=False):
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/response.py", line 353, in stream
    data = self.read(amt=amt, decode_content=decode_content)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/response.py", line 320, in read
    flush_decoder = True
    File "/usr/lib/python2.7/contextlib.py", line 35, in __exit__
    self.gen.throw(type, value, traceback)
    File "/opt/ansible-runtime/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/response.py", line 242, in _error_catcher
    raise ReadTimeoutError(self._pool, None, 'Read timed out.')
    ReadTimeoutError: HTTPSConnectionPool(host='pypi.python.org', port=443): Read timed out.
    /opt/ansible-runtime/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
    InsecurePlatformWarning
    ++ exit_fail 263 0
    ++ set +x
    ++ cat /openstack/log/instance-info/host_info_1465180263.log
    ----------------------------------------------------------------------

    - [ Current User ] ---------------------------------------------------
    ----------------------------------------------------------------------
    root
    ----------------------------------------------------------------------

    - [ Available Memory ] -----------------------------------------------
    ----------------------------------------------------------------------
    total used free shared buffers cached
    Mem: 11975 3254 8720 19 89 2146
    -/+ buffers/cache: 1018 10956
    Swap: 12255 0 12255
    Total: 24231 3254 20976
    ----------------------------------------------------------------------

    - [ Available Disk Space ] -------------------------------------------
    ----------------------------------------------------------------------
    Filesystem Size Used Avail Use% Mounted on
    udev 5.9G 4.0K 5.9G 1% /dev
    tmpfs 1.2G 1.1M 1.2G 1% /run
    /dev/dm-0 262G 122G 128G 49% /
    none 4.0K 0 4.0K 0% /sys/fs/cgroup
    none 5.0M 0 5.0M 0% /run/lock
    none 5.9G 88K 5.9G 1% /run/shm
    none 100M 28K 100M 1% /run/user
    /dev/loop0 1000G 33M 1000G 1% /srv/swift1.img
    /dev/loop1 1000G 33M 1000G 1% /srv/swift2.img
    /dev/loop2 1000G 33M 1000G 1% /srv/swift3.img
    /dev/sda1 236M 47M 177M 21% /boot
    ----------------------------------------------------------------------

    - [ Mounted Devices ] ------------------------------------------------
    ----------------------------------------------------------------------
    /dev/mapper/ubuntu--vg-root on / type ext4 (rw,errors=remount-ro)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    none on /sys/fs/cgroup type tmpfs (rw)
    none on /sys/fs/fuse/connections type fusectl (rw)
    none on /sys/kernel/debug type debugfs (rw)
    none on /sys/kernel/security type securityfs (rw)
    udev on /dev type devtmpfs (rw,mode=0755)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
    tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
    none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
    none on /run/shm type tmpfs (rw,nosuid,nodev)
    none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
    none on /sys/fs/pstore type pstore (rw)
    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,relatime,cpuset)
    cgroup on /sys/fs/cgroup/cpu type cgroup (rw,relatime,cpu)
    cgroup on /sys/fs/cgroup/cpuacct type cgroup (rw,relatime,cpuacct)
    cgroup on /sys/fs/cgroup/memory type cgroup (rw,relatime,memory)
    cgroup on /sys/fs/cgroup/devices type cgroup (rw,relatime,devices)
    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,relatime,freezer)
    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,relatime,blkio)
    cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,relatime,perf_event)
    cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,relatime,hugetlb)
    /opt/swift1.img on /srv/swift1.img type xfs (rw,noatime,nodiratime,nobarrier,logbufs=8)
    /opt/swift2.img on /srv/swift2.img type xfs (rw,noatime,nodiratime,nobarrier,logbufs=8)
    /opt/swift3.img on /srv/swift3.img type xfs (rw,noatime,nodiratime,nobarrier,logbufs=8)
    /dev/sda1 on /boot type ext2 (rw)
    systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
    ----------------------------------------------------------------------

    - [ Block Devices ] --------------------------------------------------
    ----------------------------------------------------------------------
    NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
    sda 8:0 0 278.5G 0 disk
    |-sda1 8:1 0 243M 0 part /boot
    |-sda2 8:2 0 1K 0 part
    `-sda5 8:5 0 278.2G 0 part
    |-ubuntu--vg-root (dm-0) 252:0 0 266.2G 0 lvm /
    `-ubuntu--vg-swap_1 (dm-1) 252:1 0 12G 0 lvm [SWAP]
    loop0 7:0 0 1000G 0 loop /srv/swift1.img
    loop1 7:1 0 1000G 0 loop /srv/swift2.img
    loop2 7:2 0 1000G 0 loop /srv/swift3.img
    loop3 7:3 0 1000G 0 loop
    ----------------------------------------------------------------------

    - [ Block Devices Information ] --------------------------------------
    ----------------------------------------------------------------------
    /dev/loop0: UUID="57d58700-976f-451f-9cde-9e710314ee41" TYPE="xfs"
    /dev/loop1: UUID="fbab96e8-ffee-4097-bbd6-0f0b8dd94e6c" TYPE="xfs"
    /dev/loop2: UUID="7d340ccf-8047-4c59-852d-d1130f32f039" TYPE="xfs"
    /dev/loop3: UUID="10KMKx-hr3G-GTD6-S7uE-Zpya-iELq-QYYZz0" TYPE="LVM2_member"
    /dev/sda1: UUID="43f4f67d-d8ae-49c3-9d6d-4bd76e76a16c" TYPE="ext2"
    /dev/sda5: UUID="xrbRNe-ScGQ-9NnQ-6quX-TITr-gKOS-r0WBvh" TYPE="LVM2_member"
    /dev/mapper/ubuntu--vg-root: UUID="b9d5b005-1871-425b-b88e-844e0dddf45a" TYPE="ext4"
    /dev/mapper/ubuntu--vg-swap_1: UUID="4a4c4ac3-2db9-4b46-a267-90aaed7e64c7" TYPE="swap"
    ----------------------------------------------------------------------

    - [ Block Device Partitions ] ----------------------------------------
    ----------------------------------------------------------------------
    Model: LSI LSI (scsi)
    Disk /dev/sda: 299GB
    Sector size (logical/physical): 512B/512B
    Partition Table: msdos

    Number Start End Size Type File system Flags
    1 1049kB 256MB 255MB primary ext2 boot
    2 257MB 299GB 299GB extended
    5 257MB 299GB 299GB logical lvm

    Model: Unknown (unknown)
    Disk /dev/sda1: 255MB
    Sector size (logical/physical): 512B/512B
    Partition Table: loop

    Number Start End Size File system Flags
    1 0.00B 255MB 255MB ext2

    Error: Can't have a partition outside the disk!
    Error: /dev/sda5: unrecognised disk label
    ----------------------------------------------------------------------

    - [ PV Information ] -------------------------------------------------
    ----------------------------------------------------------------------
    PV VG Fmt Attr PSize PFree
    /dev/sda5 ubuntu-vg lvm2 a-- 278.22g 44.00m
    ----------------------------------------------------------------------

    - [ VG Information ] -------------------------------------------------
    ----------------------------------------------------------------------
    VG #PV #LV #SN Attr VSize VFree
    ubuntu-vg 1 2 0 wz--n- 278.22g 44.00m
    ----------------------------------------------------------------------

    - [ LV Information ] -------------------------------------------------
    ----------------------------------------------------------------------
    LV VG Attr LSize Pool Origin Data% Move Log Copy% Convert
    root ubuntu-vg -wi-ao--- 266.21g
    swap_1 ubuntu-vg -wi-ao--- 11.97g
    ----------------------------------------------------------------------

    - [ CPU Information ] ------------------------------------------------
    ----------------------------------------------------------------------
    /usr/bin/lscpu
    Architecture: x86_64
    CPU op-mode(s): 32-bit, 64-bit
    Byte Order: Little Endian
    CPU(s): 8
    On-line CPU(s) list: 0-7
    Thread(s) per core: 1
    Core(s) per socket: 4
    Socket(s): 2
    NUMA node(s): 2
    Vendor ID: GenuineIntel
    CPU family: 6
    Model: 45
    Stepping: 7
    CPU MHz: 1200.000
    BogoMIPS: 4401.69
    Virtualization: VT-x
    L1d cache: 32K
    L1i cache: 32K
    L2 cache: 256K
    L3 cache: 10240K
    NUMA node0 CPU(s): 0-3
    NUMA node1 CPU(s): 4-7
    ----------------------------------------------------------------------

    - [ Kernel Information ] ---------------------------------------------
    ----------------------------------------------------------------------
    Linux ubuntu 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
    ----------------------------------------------------------------------

    - [ Container Information ] ------------------------------------------
    ----------------------------------------------------------------------
    ----------------------------------------------------------------------

    - [ Firewall Information ] -------------------------------------------
    ----------------------------------------------------------------------
    Chain INPUT (policy ACCEPT 89522 packets, 143M bytes)
    pkts bytes target prot opt in out source destination
    0 0 ACCEPT udp -- virbr0 * 0.0.0.0/0 0.0.0.0/0 udp dpt:53
    0 0 ACCEPT tcp -- virbr0 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:53
    0 0 ACCEPT udp -- virbr0 * 0.0.0.0/0 0.0.0.0/0 udp dpt:67
    0 0 ACCEPT tcp -- virbr0 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:67

    Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
    pkts bytes target prot opt in out source destination
    0 0 ACCEPT all -- * virbr0 0.0.0.0/0 192.168.122.0/24 ctstate RELATED,ESTABLISHED
    0 0 ACCEPT all -- virbr0 * 192.168.122.0/24 0.0.0.0/0
    0 0 ACCEPT all -- virbr0 virbr0 0.0.0.0/0 0.0.0.0/0
    0 0 REJECT all -- * virbr0 0.0.0.0/0 0.0.0.0/0 reject-with icmp-port-unreachable
    0 0 REJECT all -- virbr0 * 0.0.0.0/0 0.0.0.0/0 reject-with icmp-port-unreachable

    Chain OUTPUT (policy ACCEPT 55472 packets, 3676K bytes)
    pkts bytes target prot opt in out source destination
    0 0 ACCEPT udp -- * virbr0 0.0.0.0/0 0.0.0.0/0 udp dpt:68
    Chain PREROUTING (policy ACCEPT 2774 packets, 322K bytes)
    pkts bytes target prot opt in out source destination

    Chain INPUT (policy ACCEPT 936 packets, 132K bytes)
    pkts bytes target prot opt in out source destination

    Chain OUTPUT (policy ACCEPT 1060 packets, 70065 bytes)
    pkts bytes target prot opt in out source destination

    Chain POSTROUTING (policy ACCEPT 1060 packets, 70065 bytes)
    pkts bytes target prot opt in out source destination
    9 624 RETURN all -- * * 192.168.122.0/24 224.0.0.0/24
    0 0 RETURN all -- * * 192.168.122.0/24 255.255.255.255
    0 0 MASQUERADE tcp -- * * 192.168.122.0/24 !192.168.122.0/24 masq ports: 1024-65535
    0 0 MASQUERADE udp -- * * 192.168.122.0/24 !192.168.122.0/24 masq ports: 1024-65535
    0 0 MASQUERADE all -- * * 192.168.122.0/24 !192.168.122.0/24
    0 0 MASQUERADE all -- * eth0 0.0.0.0/0 0.0.0.0/0
    Chain PREROUTING (policy ACCEPT 100K packets, 144M bytes)
    pkts bytes target prot opt in out source destination

    Chain INPUT (policy ACCEPT 89522 packets, 143M bytes)
    pkts bytes target prot opt in out source destination

    Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
    pkts bytes target prot opt in out source destination

    Chain OUTPUT (policy ACCEPT 55472 packets, 3676K bytes)
    pkts bytes target prot opt in out source destination

    Chain POSTROUTING (policy ACCEPT 55988 packets, 3703K bytes)
    pkts bytes target prot opt in out source destination
    0 0 CHECKSUM udp -- * virbr0 0.0.0.0/0 0.0.0.0/0 udp dpt:68 CHECKSUM fill
    0 0 CHECKSUM tcp -- * * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22 CHECKSUM fill
    ----------------------------------------------------------------------

    - [ Network Devices ] ------------------------------------------------
    ----------------------------------------------------------------------
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: p1p1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:1b:21:b8:f9:14 brd ff:ff:ff:ff:ff:ff
    inet 6.6.6.6/16 brd 6.6.255.255 scope global p1p1
    valid_lft forever preferred_lft forever
    3: p1p2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:1b:21:b8:f9:15 brd ff:ff:ff:ff:ff:ff
    inet 5.5.5.5/16 brd 5.5.255.255 scope global p1p2
    valid_lft forever preferred_lft forever
    inet6 fe80::21b:21ff:feb8:f915/64 scope link
    valid_lft forever preferred_lft forever
    4: p6p1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:12:34:56:78:ee brd ff:ff:ff:ff:ff:ff
    inet 100.115.44.47/16 brd 100.115.255.255 scope global p6p1
    valid_lft forever preferred_lft forever
    inet6 fe80::212:34ff:fe56:78ee/64 scope link
    valid_lft forever preferred_lft forever
    5: p6p2: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:12:34:56:78:ea brd ff:ff:ff:ff:ff:ff
    6: br-mgmt: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
    link/ether 7e:87:b8:d7:d3:44 brd ff:ff:ff:ff:ff:ff
    inet 172.29.236.100/22 brd 172.29.239.255 scope global br-mgmt
    valid_lft forever preferred_lft forever
    inet6 fe80::7c87:b8ff:fed7:d344/64 scope link
    valid_lft forever preferred_lft forever
    7: br-vxlan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
    link/ether 76:70:9a:82:32:f1 brd ff:ff:ff:ff:ff:ff
    inet 172.29.240.100/22 brd 172.29.243.255 scope global br-vxlan
    valid_lft forever preferred_lft forever
    inet6 fe80::7470:9aff:fe82:32f1/64 scope link
    valid_lft forever preferred_lft forever
    8: br-storage: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
    link/ether 8e:a0:19:ff:8a:29 brd ff:ff:ff:ff:ff:ff
    inet 172.29.244.100/22 brd 172.29.247.255 scope global br-storage
    valid_lft forever preferred_lft forever
    inet6 fe80::8ca0:19ff:feff:8a29/64 scope link
    valid_lft forever preferred_lft forever
    9: eth12: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b6:8a:11:4b:69:89 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::b48a:11ff:fe4b:6989/64 scope link
    valid_lft forever preferred_lft forever
    10: br-vlan-veth: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br-vlan state UP group default qlen 1000
    link/ether d2:b3:fe:56:d4:6e brd ff:ff:ff:ff:ff:ff
    11: br-vlan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether d2:b3:fe:56:d4:6e brd ff:ff:ff:ff:ff:ff
    inet 172.29.248.100/22 brd 172.29.251.255 scope global br-vlan
    valid_lft forever preferred_lft forever
    inet 172.29.248.1/22 brd 172.29.251.255 scope global secondary br-vlan
    valid_lft forever preferred_lft forever
    inet6 fe80::d0b3:feff:fe56:d46e/64 scope link
    valid_lft forever preferred_lft forever
    12: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
    link/ether 4e:3d:14:75:67:78 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
    valid_lft forever preferred_lft forever
    ----------------------------------------------------------------------

    - [ Network Routes ] -------------------------------------------------
    ----------------------------------------------------------------------
    default via 100.115.0.1 dev p6p1 proto static
    5.5.0.0/16 dev p1p2 proto kernel scope link src 5.5.5.5 metric 1
    6.6.0.0/16 dev p1p1 proto kernel scope link src 6.6.6.6
    100.115.0.0/16 dev p6p1 proto kernel scope link src 100.115.44.47 metric 1
    172.29.236.0/22 dev br-mgmt proto kernel scope link src 172.29.236.100
    172.29.240.0/22 dev br-vxlan proto kernel scope link src 172.29.240.100
    172.29.244.0/22 dev br-storage proto kernel scope link src 172.29.244.100
    172.29.248.0/22 dev br-vlan proto kernel scope link src 172.29.248.100
    192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1
    ----------------------------------------------------------------------

    - [ DNS Configuration ] ----------------------------------------------
    ----------------------------------------------------------------------
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 100.115.0.1
    nameserver 127.0.1.1
    nameserver 202.98.96.68
    nameserver 8.8.8.8
    ----------------------------------------------------------------------

    - [ Trace Path from google ] -----------------------------------------
    ----------------------------------------------------------------------
    1?: [LOCALHOST] pmtu 1500
    1: 100.115.0.1 0.726ms
    1: 100.115.0.1 0.685ms
    2: no reply
    3: 182.138.98.242 24.499ms
    4: 171.208.203.73 5.681ms
    5: 202.97.45.41 36.904ms
    Too many hops: pmtu 1500
    Resume: pmtu 1500
    ----------------------------------------------------------------------

    - [ XEN Server Information ] -----------------------------------------
    ----------------------------------------------------------------------

    No xenstore Information

    ++ info_block 'Error Info - 263' 0
    ++ echo ----------------------------------------------------------------------
    ----------------------------------------------------------------------
    ++ print_info 'Error Info - 263' 0
    ++ PROC_NAME='- [ Error Info - 263 0 ] -'
    ++ printf '\n%s%s\n' '- [ Error Info - 263 0 ] -' --------------------------------------------

    - [ Error Info - 263 0 ] ---------------------------------------------
    ++ echo ----------------------------------------------------------------------
    ----------------------------------------------------------------------
    ++ [[ false = true ]]
    ++ exit_state 1
    ++ set +x
    ----------------------------------------------------------------------

    - [ Run Time = 983 seconds || 16 minutes ] ---------------------------
    ----------------------------------------------------------------------
    ----------------------------------------------------------------------

    - [ Status: Failure ] ------------------------------------------------
    ----------------------------------------------------------------------

  • I think you might be getting hit by the bug mentioned here:

    https://github.com/rcbops/rpc-openstack/issues/1037

    This issue was fixed upsteam in openstack-ansible here: https://review.openstack.org/#/c/311193/1

    I would suggest pulling down either r11.1.10 if you are trying to deploy kilo or r12.1.3 if you are deploying with liberty from the rpc-openstack repo and try again.